English French German Italian Portuguese Spanish Swedish

rotax brp

 

447 throttle problem

  • Zoltan
  • Zoltan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 3 weeks ago #16266 by Zoltan
Zoltan created the topic: 447 throttle problem
Hi,

I have a problem with my 447, engine won't accelerate when the motor temperature reach cca 80°C.
When the engine is cold receiving throottle without any problems from min to max rpm.

80°C is critical "border".
And starting engine is without any problems , cold or hot, motor starts at the first pull.

Any ideas/solutions would be appreciated :-)

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #16269 by Bill Hertzel
Bill Hertzel replied the topic: 447 throttle problem
My first test would be a compression check.
If the piston/cylinder gap is getting excessive, you may be losing compression as it warms up.

Please report the full history of this engine.
Any maintenance recently?

Bill.

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #16270 by Nick Axworthy
Nick Axworthy replied the topic: 447 throttle problem
Up until now...has it always been ok?

Nick.

Please Log in or Create an account to join the conversation.

  • Dennis Richardson
  • Dennis Richardson's Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
More
4 months 3 weeks ago #16283 by Dennis Richardson
Dennis Richardson replied the topic: 447 throttle problem
Not enough information to make a diagnosis. Early 447 engines had point Ignition systems, if this is the case it could be time to set it up properly. It sounds like like the engine is running rich, this could be from needle/needle jet wear or an indication of a engine mechanical issue. Stuck rings, failing con rod bearings come to mind. The first place to look is through the exhaust ports after you remove the exhaust manifold. Let us know what you find.
Dennis

Please Log in or Create an account to join the conversation.

  • Zoltan
  • Zoltan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 2 weeks ago #16292 by Zoltan
Zoltan replied the topic: 447 throttle problem
Thanks for the effort !
A malfunction is "allegedly" diagnosed, the problem is in the condenser.
we'll see .
I'll report to you about progress.

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #16294 by Bill Hertzel
Bill Hertzel replied the topic: 447 throttle problem
When you say it will not accelerate when Hot...

What does it sound like when you open the throttle?
Does it just continue to idle nicely?
Does it slow down or speed up a little?
Does it Mis-Fire? Sound overly rich or lean?

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #16324 by James
James replied the topic: 447 throttle problem
Curious with what causes the throttle problem. Bumping for any update.

Please Log in or Create an account to join the conversation.