English French German Italian Portuguese Spanish Swedish

rotax brp

 

914 not getting full power for takeoff

  • Steve Hirschi
  • Steve Hirschi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 month 18 hours ago - 3 weeks 4 days ago #17277 by Steve Hirschi
Steve Hirschi created the topic: 914 not getting full power for takeoff
914 UL on Europa, 230 hrs, set throttle for takeoff, engine would not develop full power. RPM was fluctuating from 4800 to 5200, mp fairly steady just under 28 psi. I recycled the throttle from idle to full throttle engine was smooth to about 28 psi, the rpm started surging again. No abnormal indications in the TCU. Power up indications prior to engine start were normal Reset the TCU momentarily with no effect. Taxied back to chocks, changed fuel filter lubed the shaft the bowden cable attached to, I assume the waste gate shaft, assured it operated freely, checked carbs for flooding, insured tubing clamps tight and tubing intact. Observed the TCU self test on power up, waste gate appeared to open and close.. Started engine taxied back to runway. The engine operated normally for a local flight of about 1.0 hrs. Attempted a takeoff a few days later and same problem occurred. What else should I check? What is the waste gate shaft supposed to be lubricated with?

I rechecked all of the hose clamps on the turbo and air box, did find a clamp between carb and manifold that seemed a little loose, tightened and ops checked, no improvement. Checked hoses too, all seemed in good shape. No old age cracks on any of the hoses.
Last Edit: 3 weeks 4 days ago by Steve Hirschi.

Please Log in or Create an account to join the conversation.

  • RotaxOwner Admin
  • RotaxOwner Admin's Avatar
  • Offline
  • Administrator
  • Administrator
More
3 weeks 4 days ago #17360 by RotaxOwner Admin
RotaxOwner Admin replied the topic: 914 not getting full power for takeoff
*bump for Steve*

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago - 2 weeks 6 days ago #17420 by Rob Seaton
Rob Seaton replied the topic: 914 not getting full power for takeoff
sounds like one of your float bowl is venting out pressure. You may need new gaskets.
Or the float bowl has been over-torqued. This splays the pins outwards and causes the floats to stick.

This message has an attachment file.
Please log in or register to see it.

Last Edit: 2 weeks 6 days ago by Rob Seaton.

Please Log in or Create an account to join the conversation.