English French German Italian Portuguese Spanish Swedish

 

Rough Running On Hard Acceleration

  • Craig Dingwall
  • Craig Dingwall's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 week 3 days ago #18794 by Craig Dingwall
Craig Dingwall created the topic: Rough Running On Hard Acceleration
Hi All,

Just throwing this out there in case someone has come across a similar problem.

I have a 912 UL 2008 with about 350hrs on it (Microlight). Carbies were balanced and serviced performed only recently and carbies overhauled by Floods probably no more than about 20 hrs ago but in time about 18 months (previous owner).

When I accelerate hard, (I know we normally accelerate smoothly but for test purposes I am going harder on the throttle) there is a definite falter first prior to the revs increasing smoothly. When I say 'falter' it is like a complete misfire, or as if it is not getting enough or too much fuel.

Also noted (not sure if the two are related) is a slight misfire in straight and level cruise which at one up is about 4100RPM, during this cruise I have also noticed that the right hand EGT indicator can drop away considerably (down to about 325 at times) then come back moments later whilst the other is ready fairly steady.

When in climb at say 5000-5600RPM then all temps stay fairly normal and equal and all seems to run fairly normally.

Whilst it is a bit hard to explain exactly what happens I was wondering if this rings a bell with anyone else?

Please Log in or Create an account to join the conversation.

More
1 week 3 days ago #18797 by Roger Lee
Roger Lee replied the topic: Rough Running On Hard Acceleration
Wouldn't shock me that the cables are hanging up on one side a tad. Not moving smoothly or as quickly through the cable sheath as the other one.

Roger Lee
LSRM-A & Rotax Instructor & Rotax IRC
Tucson, AZ Ryan Airfield (KRYN)
520-574-1080 Home (TRY HOME FIRST)
520-349-7056 Cell

Please Log in or Create an account to join the conversation.

  • Craig Dingwall
  • Craig Dingwall's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 week 3 days ago #18798 by Craig Dingwall
Craig Dingwall replied the topic: Rough Running On Hard Acceleration
mmmm, thanks Roger, I guess that would cause a carby imbalance at that point? Worth checking, I'll add it to the list.

Please Log in or Create an account to join the conversation.