English French German Italian Portuguese Spanish Swedish

 

Water Temps - Issue or not?

  • russp
  • russp's Avatar Topic Author
  • Away
  • Fresh Boarder
  • Fresh Boarder
More
6 days 19 hours ago #22834 by russp
Water Temps - Issue or not? was created by russp
Hi - 30hr engine - my water temp seems to be very consistent around 80-85 degC, I've never seen them higher than this. This seems to me to be running cold? Also there has been a drop in the coolant and a couple of small puddles under the machine a few hours back but nor recently.

I'm very wary because I had a 912 previously that ran similarly cold until eventually the rad cap finally failed and it dumped all it's coolant in flight. I'm wondering if this is a sign of a suspect pressure cap or if it's just normal behaviour. Air temps (in flight) have been around 10degC. Oil temps usually sat at around 90degC (consistently 5 to 10 deg hotter than water).

I've been told that the slight need to top up (once from min to max) and the small puddles of overflow can be caused by air in a newly filled system bleeding out - this would be consistent with the the loss of coolant having essentially stopped recently.

Any thoughts? Is this normal or indicative of an issue? Should I shell out £80 on a new pressure cap just in case?

Please Log in or Create an account to join the conversation.

  • russp
  • russp's Avatar Topic Author
  • Away
  • Fresh Boarder
  • Fresh Boarder
More
5 days 12 hours ago #22843 by russp
Replied by russp on topic Water Temps - Issue or not?
Here's what it looked like at preflight today - it's not losing a lot of water but down again to about midway between max and min. Are there any other likely explanations? How likely are Rotax to accept that's this is a warranty issue?

This message has an attachment image.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.