English French German Italian Portuguese Spanish Swedish

 

Engine keeps running

  • nmflyingfish
  • nmflyingfish's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 2 weeks ago #19853 by nmflyingfish
Engine keeps running was created by nmflyingfish
Do the mag switches in the "ON" position complete a circuit allowing the engine to run, OR do the mag switches in the "OFF" position ground the ignition causing the engine to stop (ALA old dirt bikes)? I ask because today when I tried to shut down one of the mags stayed active and the engine kept running. Fortunately another pilot was nearby and was able to shut the fuel valve; killing the engine.

I need to know where to start troubleshooting - bad switch, bad ground, faulty mag unit, etc.

Please Log in or Create an account to join the conversation.

  • Bill Hertzel
  • Bill Hertzel's Avatar
  • Away
  • Platinum Boarder
  • Platinum Boarder
More
4 months 2 weeks ago #19854 by Bill Hertzel
Replied by Bill Hertzel on topic Engine keeps running
They are "Dirt Bike" Technology.
One side of each switch goes to ground.
Ground = Engine OFF.
Open Circuit = Engine RUN.

It is most likely a bad connection and not a bad part.
Pull the wire Off of the High side of the switch.
Measure the voltage on the disconnected wire.

If you do NOT see a significant voltage, there is no continuity to the ignition module.

While you have the wire OFF, use the Ohms function to check that the switch toggles.

??????????????
Why do you need a second Pilot to turn OFF your Fuel Valve?

Please Log in or Create an account to join the conversation.

  • nmflyingfish
  • nmflyingfish's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 2 weeks ago #19858 by nmflyingfish
Replied by nmflyingfish on topic Engine keeps running
Being that is is a magneto I assume there would only be voltage on the hot side of the switch with the engine running. Am I correct?

The fuel valve on my trike is not reachable from the Pilot 1 seat and I did not trust myself to get the brake securely locked before getting out.

Please Log in or Create an account to join the conversation.

  • Bill Hertzel
  • Bill Hertzel's Avatar
  • Away
  • Platinum Boarder
  • Platinum Boarder
More
4 months 2 weeks ago #19859 by Bill Hertzel
Replied by Bill Hertzel on topic Engine keeps running

nmflyingfish wrote: Being that is is a magneto I assume there would only be voltage on the hot side of the switch with the engine running. Am I correct?

A reasonable assumption.
You might also measure ground on the wire if the points closed on a stopped engine.

What engine are we talking about?

The fuel valve on my trike is not reachable from the Pilot 1 seat and I did not trust myself to get the brake securely locked before getting out.

A design feature that should be remedied!
An Engine Out Landing checklist should include a "Close Fuel Shut-Off Valve", instruction.

Please Log in or Create an account to join the conversation.

  • nmflyingfish
  • nmflyingfish's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 2 weeks ago #19872 by nmflyingfish
Replied by nmflyingfish on topic Engine keeps running
Tested the resistance of both switches. Good switch was 0.1 ohm. The other switch varied with each time it was closed - from 1.2 ohms to 2.1 ohms. That wouldn't prevent a closed circuit and the engine did shut down when both switches were closed. BUT, because the switch didn't close previously and the resistance was high and variable I'm going to replace that switch.

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #19877 by DHeal
Replied by DHeal on topic Engine keeps running
I had a similar situation with one of the ignition switches (OTTO brand) on my RV-12. It was intermittent with the failure default mode being ON -- by wiggling the switch side-to-side one could cause the intermittent operation. Fortunately, it was an easy part to replace.

Please Log in or Create an account to join the conversation.

  • jiott
  • jiott's Avatar
  • Away
  • Gold Boarder
  • Gold Boarder
More
4 months 1 week ago #19905 by jiott
Replied by jiott on topic Engine keeps running
I had the exact same problem a while ago. It was a broken ignition wire right at the ignition module connector, which prevented that module from grounding out.

Please Log in or Create an account to join the conversation.

More
4 months 4 days ago - 4 months 4 days ago #19974 by RTX
Replied by RTX on topic Engine keeps running
If its NOT ignition switch issue it could be the following.

In the Rotax operators manual Section 4) Abnormal operation Sub section 4.6) Trouble shooting engine run: Engine keeps running with ignition off - Possible cause is - Overheating of engine and the remedy is let engine cool down at idle at approximate 2000 RPM

Manuals Can be found in this link www.rotax-owner.com/en/support-topmenu/e...s#912-series-engines

See attachment for manual reverence

This message has an attachment image.
Please log in or register to see it.

Last edit: 4 months 4 days ago by RTX.

Please Log in or Create an account to join the conversation.