fbpx

 

CHT sensor anomaly

Category: 912 / 914 Technical Questions 6 weeks ago

Dear community,

we have an anomaly which we can not explain. We have 2x CHT sensors installed on ROTAX 912ULS engine, one is on head 2 and one is installed to head 3. After startup the CHT1 - head 2 is increasing and showing up to 130-140 degrees of Celsius on Dynon while the CHT2 - head 3 is in normal operating temperatures slowly climbing 80-90 degrees of Celsius.

After higher RPM settings the CHT1 is getting back to the normal and than it works normally like CHT2. Every cold stats is the same problem.

 

We exchanged the sensor - same result.

We exchanged the cables between CHT1-CHT2 = the values just exchanged, but the problem remains.

We did check for air bubbles several times.

We did inspect all the hoses for blockage/deflection, no problem was discovered.

We checked Dynon settings, all fine.

 

We currently really don´t know where to look. Any idea? Thank you.

7981_1_CHT1_problem.pdf (You do not have access to download this file.)
  • Re: CHT sensor anomaly

    by » 6 weeks ago


    I think you found where the problem is, you said. 

    "We exchanged the cables between CHT1-CHT2 = the values just exchanged, but the problem remains."

    It sounds like a wire/wiring problem, does it not?smile


  • Re: CHT sensor anomaly

    by » 6 weeks ago


    Hi, thanks for your reply, unfortunately not. By the wires change between the sensors the wrong indication also changed from CHT1 to CHT2, but in reality the same Head 2 remains affected, no matter how we changing the cables.


  • Re: CHT sensor anomaly

    by » 6 weeks ago


    Do you have a instant reading non contact/laser ir thermometer to verify the temperatures on the ground as it warms up? Or have you tried that? To verify actual head temperatures.

    https://www.testequipmentdepot.com/fluke/thermometers-and-humidity-meters/infrared-thermometers/infrared-thermometer-62max.htm?ref=gbase&gclid=EAIaIQobChMIj9Tq7eLo6QIVA4TICh0--AgLEAQYASABEgKZq_D_BwE


  • Re: CHT sensor anomaly

    by » 6 weeks ago


    We did measured them with small differences, but nothing marginal -+5 degrees. The indication difference was almost 50 degrees of Celsius, after high RPM setting they get equal (the affected CHT sensor went back to normal) and they stays normal until the next cold start of the engine.


  • Re: CHT sensor anomaly

    by » 6 weeks ago


    So are you saying that you measured the head temperature during warm up with an independent/different instrument and not the Dynon? And when measured with a different instrument the results are the same?


You do not have permissions to reply to this topic.