fbpx

 

  • Re: Starting Issues

    by » 2 years ago


    This issue has been discussed numerous times on this forum, if you search for starting problems, SMD modules or similar you will find useful advice. If swapping them out fixes the problem then you have 2 faulty SMD ignition modules. One has probably been faulty for some time as it is an undetected failure until the second one fails.

    You can either buy a couple of new ones, send yours to Carmo Electronics for repair or swap them out for some new Ignitech units. All options are not cheap but should fix your problem.

    I've have had 3 faulty SMD modules over time and I opted to have them repaired, but next time I'll be going for the Ignitech units.


  • Re: Starting Issues

    by » 2 years ago


    i installed ignitech modules for a friend, it has been working perfectly for 5 months.

    I paid 330€ for the two modules shipped directly from the Czech Republic.

    With 90cm of wires and connectors identical to ROTAX modules.

    The length of wires allowed them to be installed on the firewall, cockpit side, away from the heat and vibrations.

    The starting is instantaneous, because they are first supplied by the battery, then when the engine is running, by the engine generator.

    We have kept the ignition control curve as intended by ROTAX, although it is possible to program it differently.

     

    Another thing, I have no commercial link with IGNITECH

    just a little experience (5 months) but I have friends who have more (4 years without problem!)


  • Re: Starting Issues

    by » 2 years ago


    Are these the somewhat older style without built in soft-start?  That's what I have, with an add-on soft start module.  Interested to see what version Ignitech supplies.


  • Re: Starting Issues

    by » 2 years ago


    Thanks for all of the helpful advice! I have gone through many of the previous forums and it seems like this is just a common breaking point for the 912 electrical systems. I was initially very suprised that I had three fail all at once but it makes sense that one may have been bad for awhile and the good one has gradually degraded. I am interested in the ignitech module install. Are any of you able to share the link or part number for the module that fits the 912 ULS? Thanks in advance!


  • Re: Starting Issues

    by » 2 years ago


    I think that by default the Ignitech units have the soft-start functionality built-in. Here's a link to their website:

    Ignitec Rotax 912

    They have just recently got approval from both the BMAA and LAA in the UK for fitment to permit (experimental) aircraft. You can speak to Andy Buchan if you have any more questions:

    Andy Buchan

     


You do not have permissions to reply to this topic.