fbpx

 

Hello,

 

We have a 912 that seems to be running rich. Only gets to 150-160 oil temp maximum, whether cruise or repeated touch and go's. Takes extended time to reach operating temps, even in warm weather.  Visual signs of unburnt fuel in staining on fuselage of aircraft.  400 hours TT, carb inspection performed by A&P at 200 hours.  Thoughts?  Leak in carbs?  Other possibilities, in order of likelihood?  Process for diagnosing? Thanks in advance! 

  • Re: 912 running rich?

    by » 12 months ago


    These temps can be very normal during cooler weather and has nothing to do with the carbs. Many place a piece of aluminum tape over the radiator and or oil cooler.

    As far as your stains, check the carbs for any leak. Some staining on the bottom many times is just oil vapors from the oil tank vent tube or exhaust vapors from the pipe.


    Roger Lee
    LSRM-A & Rotax Instructor & Rotax IRC
    Tucson, AZ Ryan Airfield (KRYN)
    520-349-7056 Cell


    Thank you said by: Nicholas Wilcox

  • Re: 912 running rich?

    by » 12 months ago


    Roger Lee wrote:

    These temps can be very normal during cooler weather and has nothing to do with the carbs. Many place a piece of aluminum tape over the radiator and or oil cooler.

    As far as your stains, check the carbs for any leak. Some staining on the bottom many times is just oil vapors from the oil tank vent tube or exhaust vapors from the pipe.

    Thanks, Roger. These temps are being observed during warm Florida weather, and with the foil tape on both radiators. Is it still common to see 150-160 in 80 degree weather and with foil tape, with long warm up time? My other 912 with no cowling warms faster and to higher temps in colder conditions in Nevada… 


  • Re: 912 running rich?

    by » 12 months ago


    Instrument error ??

     


  • Re: 912 running rich?

    by » 12 months ago


    I would think a rich running engine would be first indicated by bad performance and mileage. I wouldn’t use oil temp as the indicator. 


    Walt

    my blog; waltsrv12.com


  • Re: 912 running rich?

    by » 12 months ago


    Check the plugs to see if they're black and sooty. Maybe the carbs need be synced.


    Thank you said by: Nicholas Wilcox

You do not have permissions to reply to this topic.