fbpx

 

My oil temperature has suddenly started fluctuating up and down from normal to critical red and back (60 - 80 degree fluctuations). This happens over the course of a second or two. Seems intermittent, and does not seem to vary much with throttle. Oil Pressure is normal. I am sure the oil temperature is fine, and the reading is bad. What's the first step to trouble shooting this? Is the sensor most likely going bad?

Thanks in advance!

  • Re: Oil Temp Reading Fluctuating Up and Down

    by » 4 months ago


    This has happened to me at least a couple of times and it’s always been a bad ground to the sensor. Check that line carefully. 


  • Re: Oil Temp Reading Fluctuating Up and Down

    by » 4 months ago


    The sensors on the Rotax are all grounded through the metal of the engine, so if the oil pressure is reading correctly then it is likely that the engine grounding is OK. There could be a problem with the ground on the gauge so that might be worth a check.

    The oil temperature sensor is the same as the cylinder head sensor, you could swap them to see if the fault moves. If it doesn't then you have a signal wire or gauge problem.

    My personal experience is that the connection between the crimp terminal and the sensor terminal can degrade over time. Sometimes I have to clean them up, tighten the crimp with a pair of pliers and apply some dielectric grease.


  • Re: Oil Temp Reading Fluctuating Up and Down

    by » 4 months ago


    As Craig mentioned, it’s probably a bad electrical connection somewhere. If your engine has a “fast on” type connector at the sensor, slide it off the sensor, clean it with some spray contact cleaner & give the sensor’s contact area a light rub with red Scotch-Brite then spray it with cleaner too. Make sure the connector is tight on the sensor, give it a light squeeze with pliers. Also make sure the wire is secure in the connector.

    37927_2_IMG_2136.jpeg (You do not have access to download this file.)

  • Re: Oil Temp Reading Fluctuating Up and Down

    by » 4 months ago


    I agree. Either a poor ground connection or a lose wire.


    Roger Lee
    LSRM-A & Rotax Instructor & Rotax IRC
    Tucson, AZ Ryan Airfield (KRYN)
    520-349-7056 Cell


  • Re: Oil Temp Reading Fluctuating Up and Down

    by » 4 months ago


    I also agree with what was written. Some additional comments:

    A) I'm using Garmin GEA module to read the srnsors. I found that you must ground the wire from the sensor, close to the sensor. When the ground is loose, the reading may be wrong - more than actual, but not consistent.

    B) Crimp connection to the sensor get dirty or loose. You have to clean and tighten it, as described in previous replies.


You do not have permissions to reply to this topic.