fbpx

 

Hi,

Many times, on the first start, my engine (912 iS Sport) starts running for 1-2 seconds and then quits, or it will start but the ECU lanes red warning lights will illuminate and engine data will stop displaying on the G3X display

If the engine quits, then on the second start it will run normally, and if the engine is running with the ECU warning light illuminated, cycling the lane A&B switches ON->OFF->ON will solve the problem.

I follow the Rotax owner manual for the start procedure:

1. Fuel Pump -> ON (only 1 pump as the manual states)

2. ECU Lanes A&B -> ON

3. Start up power -> ON (ensure fuel pressure is in range and wait for ECU lanes red warning lights to extinguish)

4. Set throttle to 40%-50% power (weather is hot where I leave (typically 25-33 Celsius, 77-91 Fahrenheit)

5. Press start until the engine reached 1500+ RPM

 

I wonder if there are more people here that experience such behavior and what should I do differently

Thanks

  • Re: Engine quit right after 1st start

    by » 5 months ago


    Many 912is engines do not like to run below 2500 rpm when cold and will stop.  ????
    Keeping the RPMs high for about 10 seconds will let the symptom pass.
    Make sure you have the brakes set before cranking or it gets exciting fast!!!

    It is not uncommon for the ECU to reset on Startup.
    My engine typically turns through one compression and then stops for an instant trying to get past the second compression.
    After that, it cranks vigorously and starts after two revolutions.
    When it stalls on the second compression the battery sags as it gives its all to the starter.
    The voltage drops low enough that the ECU and the Panel Brown out momentarily, causing the reset.


    Bill Hertzel
    Rotax 912is
    North Ridgeville, OH, USA
    Bill.Hertzel@Yahoo.com
    Clicking the "Thank You" is Always Appreciated.


    Thank you said by: Uri hadar

  • Re: Engine quit right after 1st start

    by » 5 months ago


    My experience with this issue saying replace your battery in order to have higher voltage. 

    I had this problem and changing the battery solve all problems. 


    Thank you said by: Uri hadar

  • Re: Engine quit right after 1st start

    by » 5 months ago


    I agree with Micha that failure to rotate the engine more than 1 compression is a sign that your battery is in VERY poor health, and probably needs to be replaced.


  • Re: Engine quit right after 1st start

    by » 5 months ago


    This isn't that uncommon for the iS engine. I have heard many say theirs starts up then quits. Since the rpm is usually set a little low from the factory I tend to crack the throttle even though the manual says throttle all the way back. Then the start up is right at 2000 rpm and not too low to beat anything up and enough fuel to keep things going.

    Try it and see if it works for you.

    I guess this may be more a personal preference, but it does work. I usually increase the idle rpm some at the annual which seems to help and make it run a little smoother when people pull the throttle back.


    Roger Lee
    LSRM-A & Rotax Instructor & Rotax IRC
    Tucson, AZ Ryan Airfield (KRYN)
    520-349-7056 Cell


    Thank you said by: Uri hadar

  • Re: Engine quit right after 1st start

    by » 5 months ago


    Well, my procedure for turn off the engine is the following:

    When arrives at the parking, I adjust the throttle to 2300-2400 and turn off the A&B lanes.

    Next starting is with the same throttle position. 

    Together with the healthy battery no problems at all. 


You do not have permissions to reply to this topic.