I have a new 2017 912uls and have begun ground runs.  My system includes a double pole mag switch ahead of a key switch with left, right and start. During mag checks at 4000 rpm the left mag drop is 1000 rpm and the right is 300 rpm. What could be the issue?

  • Re: 912uls mag check

    by » 6 weeks ago


    I would begin by suspecting the Spark Plugs.

    It sounds like one of them is dead.

    You may just find that one plug wire is not really connected.

    Otherwise, remove the plugs and keep track of which location each came from.

    If you find one that one looks significantly different from the others, that is the place to start.


    Bill Hertzel
    Rotax 912is
    North Ridgeville, OH, USA
    whertzel1@yahoo.com
    Clicking the "Thank You" is appreciated by all.

  • Re: 912uls mag check

    by » 5 weeks ago


    Following Bill's advice, installed 4 ea. new plugs controlled by left mag, no change.  Switched mags, no change.  Bypassed keyed switch, no change.

    Any other thoughts?


  • Re: 912uls mag check

    by » 5 weeks ago


    Before hanging the engine did you verify that the ignition coil trigger gaps were within spec?  On my 912ULS the spec is .012" - .016".   See the ROTAX 912 Heavy Maint Manual for details.


  • Re: 912uls mag check

    by » 4 weeks ago


    Check your EGTs during the run up. They should give you an accurate idea of what is happening. On a Lyc/Conti the failure of one mag will cause your EGTs to rise since the mixture combustion is not complete before the exhaust valve opens. I assume that it is the same on a Rotax.

    If you have 3 normal EGTs and 1 reading very low, it means that plug is not firing and may result in a greater than normal mag drop


You do not have permissions to reply to this topic.