fbpx

 

Hi. My 880hr UL has much more metal (non magnetic) in the oil filter matting than I've had previously, this is after a 50hr oil change. I presume this isn't normal :/ Any thoughts? 

9866_1_Screenshot_20230603_210204_Gallery.jpg (You do not have access to download this file.)
  • Re: Particulates in oil filter

    by » 9 months ago


    Probably ready for a gearbox service.


  • Re: Particulates in oil filter

    by » 9 months ago


    The fragments are non magnetic, so I presume not from the gearbox ?


  • Re: Particulates in oil filter

    by » 9 months ago


    Otherers with more experience will respond, however I doubt that one troubling (metal flakes) oil filter examination, is anything more than an indication to increase your level of monitoring.The next oil filter inspection, (25 hrs?) may  show no unusual contamination.

    If you have "chunks" of metal, this would indicate a more serious situation requiring engine/G box strip down.


  • Re: Particulates in oil filter

    by » 9 months ago


    If after 880 hours I saw this kind of change in filter debris I would take it seriously.  It’s non magnetic so it’s not the gearbox.  Something has changed and I would want to know what it is.  


  • Re: Particulates in oil filter

    by » 9 months ago


    Oil contaminant analysis (in this context checking out your oil filter) is all about trend ie no one high/low reading should be taken to be absolute/in isolation.

    The exception to this would be chunks of metal or very large quantities.

    In Allen's case: Assuming engine running well with no other negative indications (oil pressure/temperature/coolant temp/ noise/etc) I would do a regular oil/filter change and monitor the situation (check oil filter at 25hr?)


You do not have permissions to reply to this topic.