HI guys, I had posted on diverse reverse polarity damages with a 912S. After having solved the glitches with the FLYDAT there still seem to be two..:
I live in Africa/Tanzania and had connected my starter battery in reverse....doing a bit of damage (Flydat/ capacitor..etc)

The engine starts well . I installed a new 1kW Starter motor..the old one didnt turn the engine any longer (cannot believe that was caused by reverse polarity!) I installed a 5,5Ah Lithium Fe Poly battery....what a revelation!!! That thing is way smaller, 1/3 of the weight, and spins they 912S (with the stronger starter)better than when afctory new! I advise : get one too!

NOw the remaining problems are:
1) The "charge light" doesn't go off after starting! and there is still no reading of RPM (wires are ok)
I checked the following according to this advice I found on the net :


the G/G contacts at the generator read 0.8-OHM between each other, but when the engine runs there is no voltage to be measured (should be 15-20V at idle and 30-40V at high rpm).If the generator shows the 0,8 OHM resistance it should be OK?

2) there is no RPM reading on FLYDAT, i checked the cables...they are ok.

Any Ideas out there?
  • Re: No Voltage from 912s generator after reversed batt

    by » 10 years ago

    RPM are taken from separated coil. You can measure resistance of this coil (between ports and ports to ground).
    It's most possible that flydat is broken. You should get voltage on revolution coil when engire is running (AC).

  • Re: No Voltage from 912s generator after reversed batt

    by » 10 years ago

    disconnect the yellow wires from the regulator and test the AC output again. The generator/stator will not be damaged by the reverse polarity but the regulator may be damaged.

  • Re: No Voltage from 912s generator after reversed batt

    by » 10 years ago

    NOw I've been through testing resistances and Voltages at the following leads with engine on and off:

    Engine ON:
    -the 2 leads from the Tach pickUp show 85mV engine ON@2700-3000rpm and 0V with OFF>I could only get a reading off my cheap consumer type Multimetre when I had it set on DC. On the "200V AC" setting it showed 0 V . At lower rpm the voltage sank to 35-50mV....but as I said the metre set at DC and probably not sensitive enough...but there's something coming out of the tach leads. The resistance of one lead was app. 270 OHM. The other was open circuit.

    -Now to the yellow generator cables (marked G G): no signal from there at any rpm! Would a cheap multimetre pick the pulses up? Between the 2 I read 0,9OHM.

    Engine OFF:
    -the two red cables (are joined in my installation) show 13,8V-13,9V
    -the black on 0v

    Engine ON:
    -the 2 red cables show 13,9 when disconnected and 14,8V connected
    -the Blue cable (last on right) shows 13,5V disconnected and 14,3V connected

    That seems ok?

    I just cant gat a reading from those two Yellow cables connected to the G G terminals!?

    Very puzzling to me!

  • Re: No Voltage from 912s generator after reversed batt

    by » 10 years ago

    Don't disconnect individually wires from regulator - it's prohibited by manual.
    I think you have problem with multimeter, try another one.
    It's not possible to damage coils by connecting with wrong polarity. You probably damage semi-conductor devices like regulator, maybe flydat.

  • Re: No Voltage from 912s generator after reversed batt

    by » 10 years ago

    If you have 14,8V on output of connected regulator it's looks good. I'm not sure if you really have more than 13V on disconnected battery.. I suggest use another, tested multimeter.

You do not have permissions to reply to this topic.