fbpx

 

Hallo

My question is difficult to put to words but ill try.

At initial startup oil pressure is fine (6Bar). Strange thing is when rpm is raised,the oil pressure drops a slight bit, +- 0,5Bar.

As the engine heats up the pressure gradially drops to +- 2Bar with the initial reduction in pressure with increseased RPM. After a little delay the pressure wil increse slightly ,again 0,5Bar.

When returning to idle the pressure inrease again to around 2,5Bar.

Any guidance to go about faultfing this problem will be appeciatted.

Kind regards

Heinricht.

  • Re: OIL PRESSURE on 912 UL engine

    by » 7 months ago


    Hi Heinrich, 

    worked on two different aircrafts with the same problem and found one common reason for both planes, bad connections.

    I found loose or corroded connections usually on the oil pressure sending unit, the electrical eyelets under the nuts are not clean which creates resistance therefore bad readings from the gauge; also found bad grounds which would also affect oil pressure readings. NOTE: there is no rust evident on the eyelets, it's just that after years the metal of the eyelet  under the nut reacts to oxygen and eventually a microscopic film forms. This can be seen when the nut is removed, the colour of the eyelet that was under the nut is usually black and not silvery or bronze colour. Replace these or clean both surfaces of the eyelet and the flat surface of the stud that holds the eyelet in place on the oil pressure sender with sandpaper. 

    Might be a good idea to install a mechanical oil pressure gauge in the system to check the pressure so you can compare between the electrical gauge and the mechanical one.  
    Hope this helps


    Thank you said by: RotaxOwner Admin

  • Re: OIL PRESSURE on 912 UL engine

    by » 7 months ago


    What Henri suggested was the solution for my similar problem, as well.  Removed the nut securing the wire to the sender, cleaned the surface of the wire ring connector as well as the surface where that ring connector contacts the sender, tightened everything back up, and Presto!  Perfect (and stable) oil pressure readings.  Hardest part of the job was getting the cowling off and then back on...  😀


    Thank you said by: RotaxOwner Admin

  • Re: OIL PRESSURE on 912 UL engine

    by » 7 months ago


    Thanks for the replies, really appreciate the assistance. What I forgot to mention was that I did fit a mechanical gauge which corresponce with the electrical gauge. Thus not indicator problem 🙈


  • Re: OIL PRESSURE on 912 UL engine

    by » 7 months ago


    I would investigate the the electrical side first.
    And then install a mechanical gauge temporarily to confirm the pressure indications.

    " At initial startup oil pressure is fine (6Bar).  "  

    SIX Bar (90psi) is NOT Fine.  5 Bar is the Redline!
    Except after a cold start, 4 Bar (60 psi) is excessive.


    Bill Hertzel
    Rotax 912is
    North Ridgeville, OH, USA
    Bill.Hertzel@Yahoo.com
    Clicking the "Thank You" is Always Appreciated.


  • Re: OIL PRESSURE on 912 UL engine

    by » 7 months ago


    Heinrich,

       I do not see a problem here. What you describe is within the Rotax parameters as described in the Manual. Or do I misunderstand your question ?. Once warm below 3500 rpm the oil pressure should be between 0.8 and 5 Bar. Above 3500 rpm from 2-5 bar. Check your particular manual and so long as you are within the ranges.


You do not have permissions to reply to this topic.