fbpx

 

Hi,

 

We have a brand new 915is which had it's first run this weekend. Did the oil purge, hydraulic lifter checks etc and it all is looking good.

 

Tried a full power run up and it got to 5,800 RPM as expected, but after pulling the throttle back we got a lane A warning light. It went away on a reset but attempting full power again brought the light back up.

 

The G3X FADEC info showed:

Lane A  - CAUTION

Waste PCV Valve - Fault

 

Any idea of where to start other than checking the connections on the solenoid pack?

  • Re: Wastegate PCV Valve Fault

    by » 4 months ago


    You could be seeing a spike in boost when you throttle back, making the ECU try to compensate for it. How fast are you throttling back? Is it a rapid pullback or gradual?

    Make sure you see positive manifold pressure(make sure the turbo is working), then Pressure test the PCV valve assembly to make sure the PCV valve is working properly. Make sure there are no kinks or sharp bends in any of the hoses.

    You should also make sure the blow-off valve is working properly.

    It would also be really helpful if the ECU data were downloaded and available for review. 


  • Re: Wastegate PCV Valve Fault

    by » 4 months ago


    Thanks for the reply. Have done a bit more testing, the fault still occurs without reducing the throttle.

     

    It happens after 20secs or so of being at a high power setting. Manifold pressure is right on 29.8 or 29.9 at the time.

     

    I'd suggest its trying to start openning the wastegate and failing for whatever reason.

     

    Turbo is working (based on manifold pressure). Hoses look ok. 

     

    Can you expand on what you mean by pressure testing the pcv valve?


  • Re: Wastegate PCV Valve Fault

    by » 4 months ago


    Before going into further testing and details of such, having a copy of the ECU Data would be essential. Do you have the ability/training to extract the data from the ECU or does someone in your area have access to the Rotax ECU Dongle and extraction training?


  • Re: Wastegate PCV Valve Fault

    by » 4 months ago


    Unfortunately not yet. I have ordered a dongle but it has not arrived yet - and we havent been able to locate one to borrow nearby.

     

     


  • Re: Wastegate PCV Valve Fault

    by » 3 weeks ago


    Hi

    Have you resolved the problem yet? It is interesting to know what was the cause.

    Regards,

    ron


You do not have permissions to reply to this topic.